Are you PCI DSS V2 compliant?

Image for article on PCI DSS V2 Compliancy

If you sell online you need to make sure your ecommerce solution is PCI DSS complaint. PCI DSS stands for Payment Card Industry Data Security Standards. To be complaint you have to meet the requirements set by the PCI Security Standards Council, www.pcisecuritystandards.org

The latest version of the Payment Card Industry Data Security Standard (PCI DSS v2.0) went into effect on January 1, 2011. If you aren’t PCI DSS V2 compliant yet you have a year to comply with the new standard, but why not start addressing it now?

At Gozooko all of our ecommerce solutions are PCI DSS V2 compliant.

We had been monitoring the development of the new standards to ensure we would be ready to meet them once they were released. Unfortunately not all ecommerce solution providers take PCI compliance as seriously as we do.

“Mitigate your risk, ensure you ecommerce solution is PCI DSS compliant. If your ecommerce solution provider won’t make it compliant, find a new provider. It’s that simple,” – the Gozooko Guys

The web site owner is held liable for compliance and data security, not the ecommerce solution provider. The impact to the site owner can range from a warning, revoking your ability to process transactions, and/or monetary fines. But that will be nothing compared to the cost if you actually have a data breach. Complying with the laws when you have a data breach could cost you into the millions.

Mitigate your risk, ensure you ecommerce solution is PCI DSS compliant. If your ecommerce solution provider won’t make it compliant, find a new provider. It’s that simple.

At Gozooko, the customer always comes first. Our lines of products are customer driven, and our goal is to meet your needs and to help your business grow. As always we welcome your comments and suggestions. We look forward to hearing from you. GozookoGuys@gozooko.com

Comments are closed.

Find TLJ on Social Media

Archives